using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:^|,\s?)(?:(?<name>[A-Z]+)=(?<val>""(?:[^""]|"")+""|(?:\\,|[^,])+))+";
string input = @"O=Acme, OU=A\,cme, CN=""My super, ""Great"" CN""";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}