re = /(?:^|,\s?)(?:(?<name>[A-Z]+)=(?<val>"(?:[^"]|"")+"|(?:\\,|[^,])+))+/
str = 'O=Acme, OU=A\\,cme, CN="My super, ""Great"" CN"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end