import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\"(\\w+)\"?(?=\\s*,))|\\W*,\\W*(\\d+)|\\((\\d)|\"(.*)?(\\W)\"\\)";
final String string = "function(1)\n"
+ "function(2, 3)\n"
+ "function(\"ABOBORA\",\"MORANGO\",\"BOLACHA\" , 44 ,55)\n"
+ "function(\"ABOBORA\",\"MORANGO\",\"BOLACHA\" \"66\")\n"
+ "function(\"ABOBORA\",\"MORANGO\",\"BOLACHA\", \"77\")\n"
+ "function(\"ABOBORA\",\"MORANGO\",\"BOLACHA\" . \"88)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}