import re
regex = re.compile(r"(?:\"(\w+)\"?(?=\s*,))|\W*,\W*(\d+)|\((\d)|\"(.*)?(\W)\"\)", flags=re.MULTILINE)
test_str = ("function(1)\n"
"function(2, 3)\n"
"function(\"ABOBORA\",\"MORANGO\",\"BOLACHA\" , 44 ,55)\n"
"function(\"ABOBORA\",\"MORANGO\",\"BOLACHA\" \"66\")\n"
"function(\"ABOBORA\",\"MORANGO\",\"BOLACHA\", \"77\")\n"
"function(\"ABOBORA\",\"MORANGO\",\"BOLACHA\" . \"88)")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")