re = /^(?<key>[^=\s]+)\s*="*(?<value>[^"]+)/m
str = 'Include =" reg2reg,in2reg,in2out,reg2out "
Include="reg2reg,in2reg,in2out,reg2out
Include=reg2reg,in2reg,in2out,reg2out"
Include=reg2reg,in2reg,in2out,reg2out
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end