const regex = /(?<=[^AZ-az]_).\S+\d/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=[^AZ-az]_).\\S+\\d', 'gm')
const str = `DM1_65_78109” OR SL1_78_72947`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}