const regex = /^\w{3}\s\w{3}\s\d{2}\s(\d{2}:\d{2}:\d{2})\s\d{4}\s([^\s]+)\s{1,2}(Retrospective verdict received).\n(?:[^\,\:]+)\:\s([^\,\"]+)\n(?:[^\,\:]+)\:\s([^\,\"]+)\n(?:[^\,\:]+)\:\s([^\,\"]+)\n(?:[^\,\:]+)\:\s([^\,\"]+)\n(?:[^:]+):\s([^\s]+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\w{3}\\s\\w{3}\\s\\d{2}\\s(\\d{2}:\\d{2}:\\d{2})\\s\\d{4}\\s([^\\s]+)\\s{1,2}(Retrospective verdict received).\\n(?:[^\\,\\:]+)\\:\\s([^\\,\\"]+)\\n(?:[^\\,\\:]+)\\:\\s([^\\,\\"]+)\\n(?:[^\\,\\:]+)\\:\\s([^\\,\\"]+)\\n(?:[^\\,\\:]+)\\:\\s([^\\,\\"]+)\\n(?:[^:]+):\\s([^\\s]+)', 'gm')
const str = `Mon Sep 24 10:40:03 2018 Info: Retrospective verdict received.
SHA256: 3137893bc260c014974de84a
Timestamp: 1537778403.1
Verdict: MALICIOUS
Reputation Score: 0
Spyname: W32.3137893BC2-96.SBX.VIOC`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}