#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(\\|[a-zA-Z]:)(\\\w[\w-.]*){2,}"
Local $sString = "\\se8p10000683" & @CRLF & _
"\\se8p10000683\appdata\aps\apsinstaller\done\abru0103-497-0018855-oav-cc-999-00zfz7g" & @CRLF & _
"\\se8p10000683\appdata\aps\apsinstaller\done\00a.bd.con" & @CRLF & _
"\\se8p10000683\appdata\aps\..\..\inetpub\ftproot" & @CRLF & _
"\\se8p10000683\appdata\aps\..\inetpub\ftproot" & @CRLF & _
"\\se8p10000683\appdata\aps\%2e" & @CRLF & _
"c:\boot.ini" & @CRLF & _
"c:\windows\notepad.exe" & @CRLF & _
"p:\appdata\aps\apsinstaller\done\abru0103-497-0018855-oav-cc-999-00zfz7g" & @CRLF & _
"p:\appdata\aps\coucou.pdf" & @CRLF & _
"\\se8p10000683\appdata\aps\%2e.pdf" & @CRLF & _
"\\se8p10000683\appdata\aps\test.pdf" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")