import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\\\|[a-zA-Z]:)(\\\\\\w[\\w-.]*){2,}";
final String string = "\\\\se8p10000683\n"
+ "\\\\se8p10000683\\appdata\\aps\\apsinstaller\\done\\abru0103-497-0018855-oav-cc-999-00zfz7g\n"
+ "\\\\se8p10000683\\appdata\\aps\\apsinstaller\\done\\00a.bd.con\n"
+ "\\\\se8p10000683\\appdata\\aps\\..\\..\\inetpub\\ftproot\n"
+ "\\\\se8p10000683\\appdata\\aps\\..\\inetpub\\ftproot\n"
+ "\\\\se8p10000683\\appdata\\aps\\%2e\n"
+ "c:\\boot.ini\n"
+ "c:\\windows\\notepad.exe\n"
+ "p:\\appdata\\aps\\apsinstaller\\done\\abru0103-497-0018855-oav-cc-999-00zfz7g\n"
+ "p:\\appdata\\aps\\coucou.pdf\n"
+ "\\\\se8p10000683\\appdata\\aps\\%2e.pdf\n"
+ "\\\\se8p10000683\\appdata\\aps\\test.pdf\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}