$re = '/(<.?:)(.*?)(:\d*?>)/m';
$str = 'unrelated <:eggplantHand:601455008440909824>::< garbage : spam:: boobs:>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);