re = /(<.?:)(.*?)(:\d*?>)/m
str = 'unrelated <:eggplantHand:601455008440909824>::< garbage : spam:: boobs:>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end