using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"ne?t\s*\.?\s*(?:profit|earnings)\s*(\.?\s*\d+\.?\d*\.?\s*(?:lakh|crore|million))";
string input = @"business venture of net profit 23.5 million dollars";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}