re = /ne?t\s*\.?\s*(?:profit|earnings)\s*(\.?\s*\d+\.?\d*\.?\s*(?:lakh|crore|million))/
str = 'business venture of net profit 23.5 million dollars'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end