#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(A[KLRZ]|C[AOT]|D[CE]|FL|GA|HI|I[ADLN]|K[SY]|LA|M[ADEINOST]|N[CDEHJMVY]|O[HKR]|P[AR]|RI|S[CD]|T[NX]|UT|V[AIT]|W[AIVY])$"
Local $sString = "AK" & @CRLF & _
"AL" & @CRLF & _
"AR" & @CRLF & _
"AZ" & @CRLF & _
"CA" & @CRLF & _
"CO" & @CRLF & _
"CT" & @CRLF & _
"DE" & @CRLF & _
"FL" & @CRLF & _
"GA" & @CRLF & _
"HI" & @CRLF & _
"IA" & @CRLF & _
"ID" & @CRLF & _
"IL" & @CRLF & _
"IN" & @CRLF & _
"KS" & @CRLF & _
"KY" & @CRLF & _
"LA" & @CRLF & _
"MA" & @CRLF & _
"MD" & @CRLF & _
"ME" & @CRLF & _
"MI" & @CRLF & _
"MN" & @CRLF & _
"MO" & @CRLF & _
"MS" & @CRLF & _
"MT" & @CRLF & _
"NC" & @CRLF & _
"ND" & @CRLF & _
"NE" & @CRLF & _
"NH" & @CRLF & _
"NJ" & @CRLF & _
"NM" & @CRLF & _
"NV" & @CRLF & _
"NY" & @CRLF & _
"OH" & @CRLF & _
"OK" & @CRLF & _
"OR" & @CRLF & _
"PA" & @CRLF & _
"RI" & @CRLF & _
"SC" & @CRLF & _
"SD" & @CRLF & _
"TN" & @CRLF & _
"TX" & @CRLF & _
"UT" & @CRLF & _
"VA" & @CRLF & _
"VT" & @CRLF & _
"WA" & @CRLF & _
"WI" & @CRLF & _
"WV" & @CRLF & _
"WY"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")