import re
regex = re.compile(r"^(A[KLRZ]|C[AOT]|D[CE]|FL|GA|HI|I[ADLN]|K[SY]|LA|M[ADEINOST]|N[CDEHJMVY]|O[HKR]|P[AR]|RI|S[CD]|T[NX]|UT|V[AIT]|W[AIVY])$", flags=re.MULTILINE)
test_str = ("AK\n"
"AL\n"
"AR\n"
"AZ\n"
"CA\n"
"CO\n"
"CT\n"
"DE\n"
"FL\n"
"GA\n"
"HI\n"
"IA\n"
"ID\n"
"IL\n"
"IN\n"
"KS\n"
"KY\n"
"LA\n"
"MA\n"
"MD\n"
"ME\n"
"MI\n"
"MN\n"
"MO\n"
"MS\n"
"MT\n"
"NC\n"
"ND\n"
"NE\n"
"NH\n"
"NJ\n"
"NM\n"
"NV\n"
"NY\n"
"OH\n"
"OK\n"
"OR\n"
"PA\n"
"RI\n"
"SC\n"
"SD\n"
"TN\n"
"TX\n"
"UT\n"
"VA\n"
"VT\n"
"WA\n"
"WI\n"
"WV\n"
"WY")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")