// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)^\w+([-+.']\w+)*@\w+([-.]\w+)*\.\w+([.]\w+)*$").unwrap();
let string = "barney@example.de
barney.rubble@example.com
barney-rubble@example.coop
barney+rubble@example.com
barney'rubble@example.com
b.arne.y_r.ubbl.e@example.com
barney4rubble@example.com
barney4rubble!@example.com
_barney+rubble@example.com
\"barney+rubble\"@example.com";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}