using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(.*?(\n.+?)?)(?:\(Reminder (\d*)\)|$)";
string input = @"L-I-F-123 Dolor sit amet.(Lorem Ipsum) (Reminder 3)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}