$re = '/^(.*?(\n.+?)?)(?:\(Reminder (\d*)\)|$)/m';
$str = 'L-I-F-123 Dolor sit amet.(Lorem Ipsum) (Reminder 3)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);