#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:^\d{1,3}(?:\.?\d{3})*(?:,\d{2})?$)|(?:^\d{1,3}(?:,?\d{3})*(?:\.\d{2})?$)"
Local $sString = "1" & @CRLF & _
"1234" & @CRLF & _
"123456" & @CRLF & _
"" & @CRLF & _
"1.234" & @CRLF & _
"123.456" & @CRLF & _
"1.234.567" & @CRLF & _
"" & @CRLF & _
"1,23" & @CRLF & _
"12345,67" & @CRLF & _
"1234567,89" & @CRLF & _
"" & @CRLF & _
"1.234,56" & @CRLF & _
"123.456,78" & @CRLF & _
"1.234.567,89" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")