import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:^\\d{1,3}(?:\\.?\\d{3})*(?:,\\d{2})?$)|(?:^\\d{1,3}(?:,?\\d{3})*(?:\\.\\d{2})?$)";
final String string = "1\n"
+ "1234\n"
+ "123456\n\n"
+ "1.234\n"
+ "123.456\n"
+ "1.234.567\n\n"
+ "1,23\n"
+ "12345,67\n"
+ "1234567,89\n\n"
+ "1.234,56\n"
+ "123.456,78\n"
+ "1.234.567,89\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}