using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*([^?]*)\%(.*)$";
string input = @"/historical-rainfall-trends-south-africa-1921%C3%A2%E2%82%AC%E2%80%9C2015.pdf";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}