re = /.*([^?]*)\%(.*)$/m
str = '/historical-rainfall-trends-south-africa-1921%C3%A2%E2%82%AC%E2%80%9C2015.pdf'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end