package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^application\/(.+\+)?json$`)
var str = `application/json
application/vnd.schemaregistry.v1+json`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}