use strict;
my $str = '4581458245834584';
my $regex = qr/(?=(?:....)*$)/p;
my $subst = '-';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";