$re = '/(?=(?:....)*$)/';
$str = '4581458245834584';
$subst = "-";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;