import re
regex = re.compile(r"(\d+).+", flags=re.MULTILINE)
test_str = ("node\n"
"1077_shift_factor_avg\n"
"1694_shift_factor_avg\n"
"1922_shift_factor_avg\n")
subst = "cnstrnt_\\1"
result = regex.sub(subst, test_str)
if result:
print(result)