using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?ms)(?<=^-- #Start\s*\r?\n).+?(?=^-- #End)";
string input = @"This is my file with content
-- #Start
This is more content
across different lines
etc etc
-- #End
This is my file with content
-- #Start
This is more content
across different lines
etc etc
-- #End
something else";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}