import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?ms)(?<=^-- #Start\\s*\\r?\\n).+?(?=^-- #End)";
final String string = "This is my file with content\n"
+ "-- #Start\n"
+ "This is more content\n"
+ "across different lines\n"
+ "etc etc\n"
+ "-- #End\n"
+ "This is my file with content\n"
+ "-- #Start\n"
+ "This is more content\n"
+ "across different lines\n"
+ "etc etc\n"
+ "-- #End\n"
+ "something else";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}