package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^[-[:alpha:] ]{2,100}$`)
var str = `Виктор-знает-об-этом`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}