$re = '/^[-[:alpha:] ]{2,100}$/u';
$str = 'Виктор-знает-об-этом';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);