const regex = /^(?:[^_\n]*_){10}([^_\n]*).*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:[^_\\n]*_){10}([^_\\n]*).*$', 'gm')
const str = `e220juju_uk_yy_aon_aon_conversion_mystore_facebook-network_ppl_primaria_myproducta_galaxycombos_20220520
e220tyty_bo_oo_aon_aon_conversion_mystore_facebook-network_ppl_lal_myproductb_wd95m4473mw_diasdecyber_20220718
`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);