re = /^(?:[^_\n]*_){10}([^_\n]*).*$/m
str = 'e220juju_uk_yy_aon_aon_conversion_mystore_facebook-network_ppl_primaria_myproducta_galaxycombos_20220520
e220tyty_bo_oo_aon_aon_conversion_mystore_facebook-network_ppl_lal_myproductb_wd95m4473mw_diasdecyber_20220718
'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result