$re = '/("[^"]*"|"[^"]*|[^"]*",)*"[^"]*"|"[^"]*|[^"]*"/';
$str = '"1232","434
34",
"df
df"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);