re = /("[^"]*"|"[^"]*|[^"]*",)*"[^"]*"|"[^"]*|[^"]*"/
str = '"1232","434
34",
"df
df"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end