import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^https?:\\/\\/www\\.example\\.com(?:\\/[a-zA-Z]+)*(?:\\/\\d+\\.html)?$";
final String string = "https://www.example.com\n"
+ "https://www.example.com/demo\n"
+ "https://www.example.com/demo/abc\n"
+ "https://www.example.com/demo/abc/123.html\n\n"
+ "不匹配:\n\n"
+ "https://www.example.com/demo/abc/efg123.html\n"
+ " (可能含有数字)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}