import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\b\\d)[\\s|]*º[\\s|]*dia";
final String string = "input_text = \"Serian 4 unidades de mermelada para el dia 04 del 8 de este año 2023\" #example 1\n"
+ "input_text = \"Hay 10 unidades para el dia 15 del 12 y seran 9 ya para el 7 de noviembre\" #example 2\n"
+ "input_text = \"Hay 10 unidades para el 15 del 1º mes del año y seran alrededor de 9 para el 7º dia del mes de noviembre\" #example 3";
final String subst = "0\\1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}