re = /(\b\d)[\s|]*º[\s|]*dia/m
str = 'input_text = "Serian 4 unidades de mermelada para el dia 04 del 8 de este año 2023" #example 1
input_text = "Hay 10 unidades para el dia 15 del 12 y seran 9 ya para el 7 de noviembre" #example 2
input_text = "Hay 10 unidades para el 15 del 1º mes del año y seran alrededor de 9 para el 7º dia del mes de noviembre" #example 3'
subst = '0\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result