#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<fileName>.+).part[a-z]"
Local $sString = "influxdb.$db.$DATE.$DOW.$HOUR.tar.bz2.parta" & @CRLF & _
"influxdb.$db.$DATE.$DOW.$HOUR.tar.bz2.partb" & @CRLF & _
"influxdb.$db.$DATE.$DOW.$HOUR.tar.bz2.partc" & @CRLF & _
"influxdb.$db.$DATE.$DOW.$HOUR.tar.bz2.parte" & @CRLF & _
"influxdb.$db.$DATE.$DOW.$HOUR.tar.bz2.partz" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")