const regex = /(?<fileName>.+).part[a-z]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<fileName>.+).part[a-z]', 'gm')
const str = `influxdb.\$db.\$DATE.\$DOW.\$HOUR.tar.bz2.parta
influxdb.\$db.\$DATE.\$DOW.\$HOUR.tar.bz2.partb
influxdb.\$db.\$DATE.\$DOW.\$HOUR.tar.bz2.partc
influxdb.\$db.\$DATE.\$DOW.\$HOUR.tar.bz2.parte
influxdb.\$db.\$DATE.\$DOW.\$HOUR.tar.bz2.partz
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}