# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:^[^.]*\.|\G(?!^))[^.]*\K\.//gm;t' <<< "59.34343.23"