$re = '/(?:^[^.]*\.|\G(?!^))[^.]*\K\./m';
$str = '59.34343.23';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;