package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:\sat\s)((?:\w+\s?){2})`)
var str = `Strawberries at Randall Farms`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}