$re = '/(?:\sat\s)((?:\w+\s?){2})/';
$str = 'Strawberries at Randall Farms';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);