$re = '/^[^@_\%+\-\.]+[^@][^@_\%+\-\.]+@[A-Za-z\.]+$/m';
$str = 'abc.abc@mail.co.uk
abc..abc@mail.co.uk';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);