re = /^[^@_\%+\-\.]+[^@][^@_\%+\-\.]+@[A-Za-z\.]+$/m
str = 'abc.abc@mail.co.uk
abc..abc@mail.co.uk'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end