const regex = /(?<=\d{2})-/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\d{2})-', 'gm')
const str = `My-birthday-is-on-the: 03-12-89`;
const subst = `\/`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);