$re = '/(?<=\d{2})-/m';
$str = 'My-birthday-is-on-the: 03-12-89';
$subst = "\/";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;