package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[a-zA-Z\-\'ÀÁÂÃÄÅàáâãäåÒÓÔÕÖØòóôõöøÈÉÊËèéêëÇçÌÍÎÏìíîïÙÚÛÜùúûüÿÑñ]{50}`)
var str = `Martin
N'guyen
Dupont-Durand
De La Lande
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}