re = /[a-zA-Z\-\'ÀÁÂÃÄÅàáâãäåÒÓÔÕÖØòóôõöøÈÉÊËèéêëÇçÌÍÎÏìíîïÙÚÛÜùúûüÿÑñ]{50}/m
str = 'Martin
N\'guyen
Dupont-Durand
De La Lande
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end