package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([0-9])\s+([0-9])\s+([A-Za-z0-9- ]+?)\s{2,}([A-Za-z0-9- ]+?)\s+([A-Za-z0-9]+)`)
var str = `1 2 CCS-7354 Series Supervisor Module 7354-SPP JD546546527`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}